|FSCK(8)||System Manager's Manual||FSCK(8)|
special | node ...]
fsckcommand invokes file system-specific programs to check the special devices listed in the fstab(5) file or in the command line for consistency. It is normally used in the script /etc/rc during automatic reboot. If no file systems are specified, and “preen” mode is enabled (
fsckreads the table /etc/fstab to determine which file systems to check, in what order. Only partitions in fstab that are mounted ``rw,'' ``rq'' or ``ro'' and that have non-zero pass number are checked. File systems with pass number 1 (normally just the root file system) are checked one at a time. When pass 1 completes, all remaining file systems are checked, running one process per disk drive. By default, file systems which are already mounted read-write are not checked. The disk drive containing each file system is inferred from the longest prefix of the device name that ends in a digit; the remaining characters are assumed to be the partition designator. The options are as follows:
fsckto assume no as the answer to all operator questions, except "CONTINUE?".
fsckwill check all file systems listed in /etc/fstab according to their pass number, and will make minor repairs without human intervention.
fsckonly for the comma separated list of file system types. If the list starts with “no” then invoke
fsckfor the file system types that are not specified in the list.
fsckto assume yes as the answer to all operator questions.
0on success. Any major problems will cause
fsckto exit with the following non-zero exit(3) codes, so as to alert any invoking program or script that human intervention is required.
fsckon the file system(s) is required.
fsckexited because of the result of a signal (usually
SIGQUITfrom the terminal).
fsckutility appeared in 4.0BSD. It was reimplemented as a file system independent wrapper in NetBSD 1.3. The original file system specific utility became fsck_ffs(8) at this point.
|September 11, 2016||NetBSD-current|