|CRASH(8)||System Manager's Manual||CRASH(8)|
crashcommand is used to examine and debug system images. If run without any arguments,
crashoperates on the running system. The options are as follows:
crash, and must be uncompressed.
crashis the same as the in-kernel debugger. See the ddb(4) manual page for more information. Operations and facilities that require a running system, such as breakpoints, are not supported by
crashdoes not provide pagination. However, by using the pipe symbol, output may be sent to commands available from the shell. For example:
crash> ps | more crash> ps | grep ioflush
# echo ps | crash | grep '^[0-9]' | cut -c 30-46 | \ sed 's,^,bt/a ,' | crash
crashcommand appeared in NetBSD 6.0.
crashcommand for the sparc port is unstable.
|March 22, 2019||NetBSD-current|